summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-27 18:36:46 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-27 18:36:46 +0100
commit21b2dac90d38b07b6f1aad1bd4aec2681c4e6e8c (patch)
tree0843d3e788cc252553da2428914e0a812eee6299 /app-text/hnb
parentx11-plugins/gkrellmss: fix build with gcc-10 (diff)
downloadgentoo-21b2dac90d38b07b6f1aad1bd4aec2681c4e6e8c.tar.gz
gentoo-21b2dac90d38b07b6f1aad1bd4aec2681c4e6e8c.tar.bz2
gentoo-21b2dac90d38b07b6f1aad1bd4aec2681c4e6e8c.zip
app-text/hnb: port to EAPI 7
Closes: https://bugs.gentoo.org/707720 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/hnb')
-rw-r--r--app-text/hnb/files/hnb-1.9.18-fno-common.patch27
-rw-r--r--app-text/hnb/hnb-1.9.18-r1.ebuild27
2 files changed, 42 insertions, 12 deletions
diff --git a/app-text/hnb/files/hnb-1.9.18-fno-common.patch b/app-text/hnb/files/hnb-1.9.18-fno-common.patch
new file mode 100644
index 000000000000..89a4321c4144
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-fno-common.patch
@@ -0,0 +1,27 @@
+--- a/src/ui.h
++++ b/src/ui.h
+@@ -38,6 +38,9 @@ extern int hnb_edit_posup;
+ extern int hnb_edit_posdown;
+
+ extern int ui_inited;
++extern int nodes_above;
++extern int active_line;
++extern int nodes_below;
+
+ void ui_getstr (char *prompt, char *datastorage);
+
+--- a/src/ui_draw.c
++++ b/src/ui_draw.c
+@@ -39,9 +39,9 @@
+
+ #define KEEPLINES 5
+
+-int nodes_above;
+-int active_line;
+-int nodes_below;
++extern int nodes_above;
++extern int active_line;
++extern int nodes_below;
+
+ static Node *up (Node *sel, Node *node)
+ {
diff --git a/app-text/hnb/hnb-1.9.18-r1.ebuild b/app-text/hnb/hnb-1.9.18-r1.ebuild
index a38796bc73be..2c262725c22e 100644
--- a/app-text/hnb/hnb-1.9.18-r1.ebuild
+++ b/app-text/hnb/hnb-1.9.18-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A program to organize many kinds of data in one place"
HOMEPAGE="http://hnb.sourceforge.net/"
@@ -13,20 +14,22 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="sys-libs/ncurses"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-printf.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
+ default
+
rm -r ${P} || die
rm src/cli_history.o || die
- epatch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-include.patch \
- "${FILESDIR}"/${P}-printf.patch
-
tc-export AR CC PKG_CONFIG
# bug #532552