summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 20:33:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:07:25 +0100
commitf778766c0afe2e4ef26d33cb033ebe1410cde605 (patch)
treefc8ad9de02db2556b0ee0a84558590e86acdbd7d /app-text/libetonyek/libetonyek-0.1.9.ebuild
parentdev-cpp/libcmis: 0.5.2 version bump (diff)
downloadgentoo-f778766c0afe2e4ef26d33cb033ebe1410cde605.tar.gz
gentoo-f778766c0afe2e4ef26d33cb033ebe1410cde605.tar.bz2
gentoo-f778766c0afe2e4ef26d33cb033ebe1410cde605.zip
app-text/libetonyek: 0.1.9 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libetonyek/libetonyek-0.1.9.ebuild')
-rw-r--r--app-text/libetonyek/libetonyek-0.1.9.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-text/libetonyek/libetonyek-0.1.9.ebuild b/app-text/libetonyek/libetonyek-0.1.9.ebuild
new file mode 100644
index 000000000000..a59ca6e00967
--- /dev/null
+++ b/app-text/libetonyek/libetonyek-0.1.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+DESCRIPTION="Library parsing Apple Keynote presentations"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ app-text/liblangtag
+ dev-libs/librevenge
+ dev-libs/libxml2
+ >=dev-util/mdds-1.3.1:1=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+ if has_version ">=dev-util/mdds-1.4"; then
+ myeconfargs+=( --with-mdds=1.4 )
+ else
+ myeconfargs+=( --with-mdds=1.2 )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}