summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 19:53:34 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 20:01:22 -0400
commit53cdd593c90f8bab8c49877b6f687277860c64e1 (patch)
treeecd37c478f16800934835190cb0e9c23078cd25e /app-text/pytextile/pytextile-3.0.3.ebuild
parentapp-forensics/foremost: Remove old package with QA issue. (diff)
downloadgentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.tar.gz
gentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.tar.bz2
gentoo-53cdd593c90f8bab8c49877b6f687277860c64e1.zip
app-text/pytextile: bump to 3.0.3
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/pytextile/pytextile-3.0.3.ebuild')
-rw-r--r--app-text/pytextile/pytextile-3.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-3.0.3.ebuild b/app-text/pytextile/pytextile-3.0.3.ebuild
new file mode 100644
index 000000000000..ffe603741631
--- /dev/null
+++ b/app-text/pytextile/pytextile-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+MY_PN="python-textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # remove useless --cov arg injection
+ rm pytest.ini || die
+ # remove useless pytest-runner dep
+ sed -e "s/pytest-runner//g" -i setup.py || die
+}
+
+python_test() {
+ pytest || die "Testsuite failed under ${EPYTHON}"
+}