summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 19:54:16 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 20:01:22 -0400
commit9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4 (patch)
tree794d3eec9e9986b53af665ac64060426b5221c71 /app-text/pytextile
parentapp-text/pytextile: bump to 3.0.3 (diff)
downloadgentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.tar.gz
gentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.tar.bz2
gentoo-9f7f6e2659dd3d4aa5a5d1f67a86ef79bdcd2ed4.zip
app-text/pytextile: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/pytextile')
-rw-r--r--app-text/pytextile/Manifest1
-rw-r--r--app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch15
-rw-r--r--app-text/pytextile/pytextile-2.1.8.ebuild38
3 files changed, 0 insertions, 54 deletions
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index f70b76be1d6d..781743a9264a 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1,3 +1,2 @@
DIST pytextile-2.3.3.tar.gz 42277 BLAKE2B a6e6e1d96695f3ada03f5da9bd8bd19b99da345d83c62b1d4f2e765303dfbbbee072da4611f1b29b46d28ed334373c809117940ff0c1238dea3b12fb9076656c SHA512 980c872bfdc056753fa5b344cbc828dbdc9ddfc2656f3cfb5c15b3351cfd9e4016f57af14b60af2f2764e556865301d7923a8f0687c5857fc2201bf10f56ab60
DIST pytextile-3.0.3.tar.gz 48560 BLAKE2B f8d3077e2b8e4de7157dcd9ed17f7889301946c2d3034dbbb0171b4930bd7268c65ce1f950552db2b783aa48acae639d5f4ccfcbca96807562b4a6377c3dd220 SHA512 142fe77c8858b0444428f9ca0f24d1a054a1566f85f00fd5cf860bb705a19666249cd03420d258d5acfc9f45052dd25e52767492a60a10d986d86b711b54612f
-DIST textile-2.1.8.tar.gz 34002 BLAKE2B 0f4643da3cf47cd9b27e7b3237c6eac8b951caab9f6f36da929e159d582ae9e8ac04b835bd9006d7392ed935a875e169eef276caa52e25d618cdeafa27cef626 SHA512 b1675a131b482f4926efb45312b16c722ff158d9296704918b56316d470056f986ce18d495525a8e9f236bdd62e09ca6a17b443a7db8c8c36e5d05fcffce67da
diff --git a/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch b/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch
deleted file mode 100644
index 1a9e696f21e9..000000000000
--- a/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/textile/python-textile/commit/83c81db387fa5f0c5ca25c27b8bc36d105bce599
-diff --git a/textile/tools/sanitizer.py b/textile/tools/sanitizer.py
-index 83b6799..4fc8fb2 100644
---- a/textile/tools/sanitizer.py
-+++ b/textile/tools/sanitizer.py
-@@ -12,7 +12,7 @@ def sanitize(string):
- p = html5lib.HTMLParser(tokenizer=sanitizer.HTMLSanitizer)
- tree = p.parseFragment(string)
-
-- walker = treewalkers.getTreeWalker("simpletree")
-+ walker = treewalkers.getTreeWalker("etree")
- stream = walker(tree)
-
- s = serializer.htmlserializer.HTMLSerializer(omit_optional_tags=False,
-
diff --git a/app-text/pytextile/pytextile-2.1.8.ebuild b/app-text/pytextile/pytextile-2.1.8.ebuild
deleted file mode 100644
index 583464ba033b..000000000000
--- a/app-text/pytextile/pytextile-2.1.8.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN="textile"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python port of Textile, A humane web text generator"
-HOMEPAGE="https://github.com/ikirudennis/python-textile"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${P}-sanitizer.patch )
-
-python_prepare_all() {
- # This resolves a nasty race condition noted and observed by Arfrever
- sed -e 's:with-id = 1::' -i setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests textile/tests/ || die "Tests failed under ${EPYTHON}"
-}