summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 03:31:15 +0000
committerSam James <sam@gentoo.org>2021-05-09 03:54:01 +0000
commit3012979ebea857a513d50993bf7853cddd06e628 (patch)
tree52ee674fbc2ccbbf23b67c4443e6981db0f08033 /app-text/qpdf/qpdf-10.3.2.ebuild
parentsys-fs/squashfs-tools-ng: Version bump to 1.1.1 (diff)
downloadgentoo-3012979ebea857a513d50993bf7853cddd06e628.tar.gz
gentoo-3012979ebea857a513d50993bf7853cddd06e628.tar.bz2
gentoo-3012979ebea857a513d50993bf7853cddd06e628.zip
app-text/qpdf: add 10.3.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/qpdf/qpdf-10.3.2.ebuild')
-rw-r--r--app-text/qpdf/qpdf-10.3.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/qpdf/qpdf-10.3.2.ebuild b/app-text/qpdf/qpdf-10.3.2.ebuild
new file mode 100644
index 000000000000..42acbd1e5cbf
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/gnutls:0=
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ dev-libs/openssl:0=
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-implicit-crypto
+ --enable-crypto-gnutls
+ --enable-crypto-native
+ --with-default-crypto=gnutls
+ --disable-static
+ $(use_enable ssl crypto-openssl)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}