summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 15:55:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:32:58 +0200
commitdbf67fc2e4b4b36720e29d6dcec64f6b5a3af580 (patch)
treeb8b0ba139bd98db073d283311ed69e790ec868cc /app-text/vgrep/vgrep-2.5.2.ebuild
parentsys-apps/fwupd: bump to v1.7.0 (diff)
downloadgentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.tar.gz
gentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.tar.bz2
gentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.zip
app-text/vgrep: bump to v2.5.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text/vgrep/vgrep-2.5.2.ebuild')
-rw-r--r--app-text/vgrep/vgrep-2.5.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/vgrep/vgrep-2.5.2.ebuild b/app-text/vgrep/vgrep-2.5.2.ebuild
new file mode 100644
index 000000000000..8946ea7fa45b
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ einstalldocs
+}