summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-02-13 20:21:24 +0100
committerFabian Groffen <grobian@gentoo.org>2020-02-13 20:21:39 +0100
commitc9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9 (patch)
tree872703b155082fb3d0575acfcbf99c28817783fe /app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
parentsys-apps/util-linux: Don't RDEPEND on virtual/os-headers (diff)
downloadgentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.tar.gz
gentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.tar.bz2
gentoo-c9322d96fc5e4fe5dbffdb6970851d6c04bd3ae9.zip
app-text/vilistextum-2.8.0.20191023-r1: add fix for list alignment
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild')
-rw-r--r--app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild b/app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
new file mode 100644
index 000000000000..2396c7dc0d6f
--- /dev/null
+++ b/app-text/vilistextum/vilistextum-2.8.0.20191023-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+GITID="f299bb5e5f661c345c4b85a3e8de9ad8615ad17a"
+DESCRIPTION="HTML to ASCII converter programmed to handle incorrect html"
+HOMEPAGE="https://bhaak.net/vilistextum/"
+SRC_URI="https://github.com/bhaak/vilistextum/tarball/${GITID} -> ${P}.tar.gz"
+S="${WORKDIR}/bhaak-${PN}-${GITID:0:7}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="unicode"
+
+DEPEND="virtual/libiconv"
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.8.0-gentoo.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-prefix.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-blockquote.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-towlower.patch"
+ eapply "${FILESDIR}/${PN}-2.8.0-list-alignment.patch"
+
+ eapply_user
+ eautoreconf
+
+ # wcscasecmp needs extensions, which aren't enabled
+ export ac_cv_func_wcscasecmp=no
+}
+
+get_locale() {
+ locale -a | grep -i "$1\.utf.*8\$"
+}
+
+find_locale() {
+ local l t
+
+ # we basically prefer to find en_US.UTF-8, but it may not always be
+ # available, in which case it is better not to hardcode to use it
+ l=$(get_locale en_US)
+ if [[ -z ${l} ]] ; then
+ for t in "en_GB" "en_.*" ".*" ; do
+ l=$(get_locale ${t})
+ if [[ -n ${l} ]] ; then
+ l=${l%%$'\n'*}
+ break;
+ fi
+ done
+ fi
+ [[ -z ${l} ]] && die "Failed to find a unicode locale"
+ echo "${l}"
+}
+
+src_configure() {
+ # need hardwired locale simply because locale -a | grep -i utf-8 | head -n1
+ # isn't always returning the most sensical (and working) locale
+ econf \
+ $(use_enable unicode multibyte) \
+ $(use_with unicode unicode-locale $(find_locale))
+}
+
+src_test() {
+ if $(locale -a | grep -iq "en_US\.utf.*8"); then
+ emake -j1 check
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.UTF-8 is installed."
+ die "en_US.UTF-8 locale is missing"
+ fi
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ dodoc doc/changes.xhtml doc/htmlmail.xhtml
+}