summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-26 11:06:20 +0100
committerMarek Szuba <marecki@gentoo.org>2021-05-26 12:21:52 +0100
commit918fcce1032df3ba911feb2b66e8eddabf6f6e63 (patch)
tree04f1945572482e2738aa230bbbdb5c6458202fc2 /app-text
parentsci-mathematics/rw: remove old "unused" rw-0.8-r3.ebuild. (diff)
downloadgentoo-918fcce1032df3ba911feb2b66e8eddabf6f6e63.tar.gz
gentoo-918fcce1032df3ba911feb2b66e8eddabf6f6e63.tar.bz2
gentoo-918fcce1032df3ba911feb2b66e8eddabf6f6e63.zip
app-text/bibletime: call xdg_icon_cache_update
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/bibletime-3.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-text/bibletime/bibletime-3.0.ebuild b/app-text/bibletime/bibletime-3.0.ebuild
index 2291044e8729..a36584eb0509 100644
--- a/app-text/bibletime/bibletime-3.0.ebuild
+++ b/app-text/bibletime/bibletime-3.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
VIRTUALX_REQUIRED=test
-inherit cmake virtualx
+inherit cmake virtualx xdg-utils
DESCRIPTION="Qt Bible-study application using the SWORD library"
HOMEPAGE="http://bibletime.info/"
@@ -66,3 +66,11 @@ src_configure() {
src_test() {
virtx cmake_src_test || die "Test run has failed"
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}