summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-10-30 20:38:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:51:27 +0100
commite3751aa7badec2f69d7950224de386c90b3262d1 (patch)
treef883eb9d254851359bd626e5c6534341c974fcdd /app-vim/jedi/jedi-0.8_p20171015.ebuild
parentdev-embedded/avr-libc: stable 2.0.0 for amd64, bug #620316 (thanks to Richard... (diff)
downloadgentoo-e3751aa7badec2f69d7950224de386c90b3262d1.tar.gz
gentoo-e3751aa7badec2f69d7950224de386c90b3262d1.tar.bz2
gentoo-e3751aa7badec2f69d7950224de386c90b3262d1.zip
app-vim/jedi-vim: new ebuild.
Vim plugin to the autocompletion library Jedi. Package-Manager: Portage-2.3.11, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6093
Diffstat (limited to 'app-vim/jedi/jedi-0.8_p20171015.ebuild')
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/jedi/jedi-0.8_p20171015.ebuild b/app-vim/jedi/jedi-0.8_p20171015.ebuild
new file mode 100644
index 000000000000..e991f5795bf7
--- /dev/null
+++ b/app-vim/jedi/jedi-0.8_p20171015.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit vim-plugin python-r1 python-utils-r1
+
+# Commit Date: Sun Oct 15 20:51:54 2017 +0200
+COMMIT="77924398bd594e238766153cec97ace62650f082"
+
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${COMMIT}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]"
+DEPEND="app-editors/vim[python]"
+
+S="${WORKDIR}/jedi-vim-${COMMIT}"
+
+# Tests are broken.
+RESTRICT="test"
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+}