summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-07 08:15:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-07 10:35:04 +0000
commita022c6369464a94a3b28720d28aa4928e799ec7c (patch)
tree696fbdc31698360153a7378c03c7a7c5c7a3a358 /app-vim/vim-flake8/vim-flake8-1.6.ebuild
parentapp-office/upwork: Remove Old (diff)
downloadgentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.tar.gz
gentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.tar.bz2
gentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.zip
app-vim/vim-flake8: Add vim-flake8 vim script.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/vim-flake8/vim-flake8-1.6.ebuild')
-rw-r--r--app-vim/vim-flake8/vim-flake8-1.6.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-vim/vim-flake8/vim-flake8-1.6.ebuild b/app-vim/vim-flake8/vim-flake8-1.6.ebuild
new file mode 100644
index 000000000000..2b924a52a00b
--- /dev/null
+++ b/app-vim/vim-flake8/vim-flake8-1.6.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: runs the currently open file through flake8"
+HOMEPAGE="https://github.com/nvie/vim-flake8"
+SRC_URI="https://github.com/nvie/${PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/flake8"