summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-24 23:33:41 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-24 23:33:41 -0400
commit7b7c49580b74f9e18906cf58ef8d661a96e902c6 (patch)
tree8de04189845a75d24f211735d6711f64e84faa4e /app-vim/vim-r/vim-r-1.2.6.ebuild
parentwww-client/lynx: version bump (diff)
downloadgentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.tar.gz
gentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.tar.bz2
gentoo-7b7c49580b74f9e18906cf58ef8d661a96e902c6.zip
app-vim/vim-r: version bump
Diffstat (limited to 'app-vim/vim-r/vim-r-1.2.6.ebuild')
-rw-r--r--app-vim/vim-r/vim-r-1.2.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/vim-r/vim-r-1.2.6.ebuild b/app-vim/vim-r/vim-r-1.2.6.ebuild
new file mode 100644
index 000000000000..6da98773669e
--- /dev/null
+++ b/app-vim/vim-r/vim-r-1.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: integrate vim with R"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2628"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/R"
+
+VIM_PLUGIN_HELPFILES="r-plugin.txt"
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "This plugin requires the vimcom R package to be installed,"
+ elog "see https://github.com/jalvesaq/VimCom for instructions."
+ fi
+}