summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-02-23 08:59:20 -0800
committerSam James <sam@gentoo.org>2024-03-21 02:50:00 +0000
commitbe1ece7a925bfb986e2dcaf7a341d8d01864018b (patch)
treed1893eb2f4515c97d2652948dda8f3ff7d1d8989 /dev-build/samurai/samurai-1.2-r3.ebuild
parentdev-build/samurai: update maintainers (diff)
downloadgentoo-be1ece7a925bfb986e2dcaf7a341d8d01864018b.tar.gz
gentoo-be1ece7a925bfb986e2dcaf7a341d8d01864018b.tar.bz2
gentoo-be1ece7a925bfb986e2dcaf7a341d8d01864018b.zip
dev-build/samurai: fix segfault for phony targets
Upstream-Issue: https://github.com/michaelforney/samurai/issues/66 Upstream-Issue: https://github.com/michaelforney/samurai/issues/81 Upstream-Commit: https://github.com/michaelforney/samurai/commit/fb61f22c7e690715d309c41812412c4f432ef53a Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/35508 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build/samurai/samurai-1.2-r3.ebuild')
-rw-r--r--dev-build/samurai/samurai-1.2-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-build/samurai/samurai-1.2-r3.ebuild b/dev-build/samurai/samurai-1.2-r3.ebuild
new file mode 100644
index 000000000000..4015659f2356
--- /dev/null
+++ b/dev-build/samurai/samurai-1.2-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ninja-compatible build tool written in C"
+HOMEPAGE="https://github.com/michaelforney/samurai"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/michaelforney/samurai.git"
+else
+ SRC_URI="https://github.com/michaelforney/samurai/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
+fi
+
+LICENSE="ISC Apache-2.0 MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-null_pointer_fix.patch" # 786951
+ "${FILESDIR}/${P}-phony_targets_fix.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.md
+}