summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/samurai/samurai-1.2-r3.ebuild')
-rw-r--r--dev-build/samurai/samurai-1.2-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-build/samurai/samurai-1.2-r3.ebuild b/dev-build/samurai/samurai-1.2-r3.ebuild
new file mode 100644
index 000000000000..4015659f2356
--- /dev/null
+++ b/dev-build/samurai/samurai-1.2-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ninja-compatible build tool written in C"
+HOMEPAGE="https://github.com/michaelforney/samurai"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/michaelforney/samurai.git"
+else
+ SRC_URI="https://github.com/michaelforney/samurai/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
+fi
+
+LICENSE="ISC Apache-2.0 MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-null_pointer_fix.patch" # 786951
+ "${FILESDIR}/${P}-phony_targets_fix.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.md
+}