summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-26 19:00:02 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-26 19:00:02 +0200
commitf749843d9b856f9686d37e6cd6cd6ee7920af3d4 (patch)
tree2d3864f0079d0cf4d0c50c8418387ba4a33ca499 /dev-cpp/catch/files
parentdev-lang/spidermonkey: use CONFIG_SHELL instead of SHELL (diff)
downloadgentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.tar.gz
gentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.tar.bz2
gentoo-f749843d9b856f9686d37e6cd6cd6ee7920af3d4.zip
dev-cpp/catch: Remove old
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch/files')
-rw-r--r--dev-cpp/catch/files/catch-2.3.0-python-automagic.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
deleted file mode 100644
index c7fa4c6d22f6..000000000000
--- a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -36,7 +36,11 @@
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /ENTRY:wmainCRTStartup")
- endif()
-
-+find_package(PythonInterp)
- if (BUILD_TESTING AND CATCH_BUILD_TESTING AND NOT_SUBPROJECT)
-+ if (NOT PYTHONINTERP_FOUND)
-+ message(FATAL_ERROR "Python not found, but required for tests")
-+ endif()
- add_subdirectory(projects)
- endif()
-
---- a/projects/CMakeLists.txt
-+++ b/projects/CMakeLists.txt
-@@ -317,7 +317,7 @@
- set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
-
- # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
--add_test(NAME ApprovalTests COMMAND python ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
-+add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
- set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
-
- if (CATCH_USE_VALGRIND)