summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-17 17:34:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-18 00:39:45 +0100
commit83a088ef3b1f8c5714e9b77adcb1b00a07790724 (patch)
tree09c44cef4b9805844a0b81fcf2df2b790e91d169 /dev-cpp/curlpp/curlpp-0.8.1.ebuild
parentdev-ml/atd: bump to 2.11.0 (diff)
downloadgentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.tar.gz
gentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.tar.bz2
gentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.zip
dev-cpp/curlpp: new package, add 0.8.1
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/29638 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-cpp/curlpp/curlpp-0.8.1.ebuild')
-rw-r--r--dev-cpp/curlpp/curlpp-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/curlpp/curlpp-0.8.1.ebuild b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
new file mode 100644
index 000000000000..8f19bb669879
--- /dev/null
+++ b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrapper for libcURL"
+HOMEPAGE="https://www.curlpp.org/"
+SRC_URI="https://github.com/jpbarrette/curlpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md doc/AUTHORS doc/TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-fix-pkgconfig.patch )
+
+src_install() {
+ use doc && DOCS+=( doc/guide.pdf )
+
+ cmake_src_install
+
+ rm "${ED}"/usr/$(get_libdir)/libcurlpp.a || die
+
+ if use examples ; then
+ dodoc -r examples/
+ fi
+}