summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-08 04:21:36 +0000
committerSam James <sam@gentoo.org>2023-01-08 04:55:07 +0000
commitf76d6ead4ed5c973823443edbd1e7f3ec32dd94d (patch)
treec8edb4a9999f47a6d0ea5da3631e6adeff4cec0c /dev-cpp/magic_enum/magic_enum-0.8.2.ebuild
parentdev-libs/miniaudio: EAPI 8, fix LICENSE (diff)
downloadgentoo-f76d6ead4ed5c973823443edbd1e7f3ec32dd94d.tar.gz
gentoo-f76d6ead4ed5c973823443edbd1e7f3ec32dd94d.tar.bz2
gentoo-f76d6ead4ed5c973823443edbd1e7f3ec32dd94d.zip
dev-cpp/magic_enum: new package, add 0.8.2
Needed for games-strategy/ja2-stracciatella in future, possibly. I packaged this given I thought it was required but ended up finding it was toggled on unnecessarily. It's cheap to build and it's likely it'll be needed in future, so.. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/magic_enum/magic_enum-0.8.2.ebuild')
-rw-r--r--dev-cpp/magic_enum/magic_enum-0.8.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild b/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild
new file mode 100644
index 000000000000..df1937ee496b
--- /dev/null
+++ b/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# As of 0.8.2, it has meson, but only for subproject use(?)
+# Doesn't install anything.
+inherit cmake
+
+DESCRIPTION="Static reflection for enums in header-only C++"
+HOMEPAGE="https://github.com/Neargye/magic_enum"
+SRC_URI="https://github.com/Neargye/magic_enum/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# Tests fail to compile
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAGIC_ENUM_OPT_BUILD_TESTS=$(usex test)
+ -DMAGIC_ENUM_OPT_INSTALL=ON
+ )
+
+ cmake_src_configure
+}