summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-30 21:19:39 +0000
committerSam James <sam@gentoo.org>2020-10-08 20:16:08 +0000
commitadb952e04174d932eb899f64892b2ff5ce0463fc (patch)
treec24c7ab8b831f4092024525228659d5a255c68db /dev-cpp/robin-map/robin-map-0.6.3.ebuild
parentdev-util/catalyst: Finish removing IUSE=system-bootloader (diff)
downloadgentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.tar.gz
gentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.tar.bz2
gentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.zip
dev-cpp/robin-map: new package (fast robinhood hashing in c++)
new dependency for media-libs/openimageio Closes: https://bugs.gentoo.org/678292 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/robin-map/robin-map-0.6.3.ebuild')
-rw-r--r--dev-cpp/robin-map/robin-map-0.6.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-cpp/robin-map/robin-map-0.6.3.ebuild b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
new file mode 100644
index 000000000000..99255a6ea187
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"