summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 21:01:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:24 +0100
commit31e21551da418ddc7a177c7c869070e9acca817c (patch)
tree0ad1bfcfc7068989bcb92c3f4499f5a84cfd8c95 /dev-cpp
parent*/*: Switch games proj to cmake.eclass (diff)
downloadgentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.gz
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.bz2
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.zip
*/*: Switch candrews' packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.4.ebuild5
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.5.ebuild5
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.6.ebuild5
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.7.ebuild5
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild5
5 files changed, 10 insertions, 15 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.4.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.4.ebuild
index c176d851c87e..5f2963921d96 100644
--- a/dev-cpp/waylandpp/waylandpp-0.2.4.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -35,8 +35,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.5.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.5.ebuild
index ea9a34e1e54b..582d9582390c 100644
--- a/dev-cpp/waylandpp/waylandpp-0.2.5.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.2.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -35,8 +35,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.6.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.6.ebuild
index ea9a34e1e54b..582d9582390c 100644
--- a/dev-cpp/waylandpp/waylandpp-0.2.6.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.2.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -35,8 +35,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
index ea9a34e1e54b..582d9582390c 100644
--- a/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -35,8 +35,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index ea9a34e1e54b..582d9582390c 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -35,8 +35,7 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}