summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 21:08:48 +0000
committerSam James <sam@gentoo.org>2021-01-02 21:08:53 +0000
commitb303773638d9da63596101266686762a5c6712d4 (patch)
treecd3c01cf834d50361963d56fb95bb1cc3561e5fe /dev-cpp
parentnet-misc/iperf: fix DOCS array (diff)
downloadgentoo-b303773638d9da63596101266686762a5c6712d4.tar.gz
gentoo-b303773638d9da63596101266686762a5c6712d4.tar.bz2
gentoo-b303773638d9da63596101266686762a5c6712d4.zip
dev-cpp/nlohmann_json: (really) build tests conditionally
Closes: https://bugs.gentoo.org/763177 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index cbad769efb0c..dda1074ac3b3 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,18 +25,20 @@ DEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog.md README.md )
src_configure() {
+ # Tests are built by default so we can't group the test logic below
local mycmakeargs=(
-DJSON_MultipleHeaders=ON
+ -DJSON_BuildTests=$(usex test)
)
if use test ; then
# Define test data directory here to avoid unused var QA warning
# #747826
mycmakeargs+=(
- -DJSON_BuildTests=ON
-DJSON_TestDataDirectory="${S}/json_test_data"
)
fi
+
cmake_src_configure
}