summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index cbad769efb0c..dda1074ac3b3 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,18 +25,20 @@ DEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog.md README.md )
src_configure() {
+ # Tests are built by default so we can't group the test logic below
local mycmakeargs=(
-DJSON_MultipleHeaders=ON
+ -DJSON_BuildTests=$(usex test)
)
if use test ; then
# Define test data directory here to avoid unused var QA warning
# #747826
mycmakeargs+=(
- -DJSON_BuildTests=ON
-DJSON_TestDataDirectory="${S}/json_test_data"
)
fi
+
cmake_src_configure
}