summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-26 23:10:02 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-26 23:10:32 +0200
commit6bbe00572dc99d5bbf563da2b8090c83a24a6aea (patch)
tree27fc1d66a4c82290a021efd32988fd711ef5cdd0 /dev-db/mysql
parentsys-cluster/sanlock: add version 3.6.0 (diff)
downloadgentoo-6bbe00572dc99d5bbf563da2b8090c83a24a6aea.tar.gz
gentoo-6bbe00572dc99d5bbf563da2b8090c83a24a6aea.tar.bz2
gentoo-6bbe00572dc99d5bbf563da2b8090c83a24a6aea.zip
dev-db/mysql: disable unstable test main.xa_prepared_binlog_off
Bug: https://bugs.mysql.com/bug.php?id=83340 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/mysql-5.7.23-r2.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.7.24.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-db/mysql/mysql-5.7.23-r2.ebuild b/dev-db/mysql/mysql-5.7.23-r2.ebuild
index 244487023056..22c2f756ecc0 100644
--- a/dev-db/mysql/mysql-5.7.23-r2.ebuild
+++ b/dev-db/mysql/mysql-5.7.23-r2.ebuild
@@ -542,6 +542,12 @@ src_test() {
_disable_test "$t" "False positives in Gentoo"
done
+ # Unstable tests
+ # - main.xa_prepared_binlog_off: https://bugs.mysql.com/bug.php?id=83340
+ for t in main.xa_prepared_binlog_off ; do
+ _disable_test "$t" "Unstable test"
+ done
+
if use numa && use kernel_linux ; then
# bug 584880
if ! linux_config_exists || ! linux_chkconfig_present NUMA ; then
diff --git a/dev-db/mysql/mysql-5.7.24.ebuild b/dev-db/mysql/mysql-5.7.24.ebuild
index 4482c8365ed0..18f5cd12d4a6 100644
--- a/dev-db/mysql/mysql-5.7.24.ebuild
+++ b/dev-db/mysql/mysql-5.7.24.ebuild
@@ -542,6 +542,12 @@ src_test() {
_disable_test "$t" "False positives in Gentoo"
done
+ # Unstable tests
+ # - main.xa_prepared_binlog_off: https://bugs.mysql.com/bug.php?id=83340
+ for t in main.xa_prepared_binlog_off ; do
+ _disable_test "$t" "Unstable test"
+ done
+
if use numa && use kernel_linux ; then
# bug 584880
if ! linux_config_exists || ! linux_chkconfig_present NUMA ; then