summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-04-20 02:04:40 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-23 09:36:26 +0300
commit99cbd51f902a056a90dfc868d280f235e3bbc0f8 (patch)
treeb0a359ed33b8d57173dbb72a14fe7e848005615f /dev-db/sadisplay/sadisplay-0.4.9.ebuild
parentapp-emulation/virtio-win: removed older version 0.1.160 (diff)
downloadgentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.tar.gz
gentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.tar.bz2
gentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.zip
dev-db/sadisplay: version bump 0.4.9, bug #718272
and PYTHON_COMPAT update Closes: https://bugs.gentoo.org/718272 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/15437 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/sadisplay/sadisplay-0.4.9.ebuild')
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-db/sadisplay/sadisplay-0.4.9.ebuild b/dev-db/sadisplay/sadisplay-0.4.9.ebuild
new file mode 100644
index 000000000000..fba6f55c38ae
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest