summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-19 21:54:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-19 22:15:07 +0100
commit9d383193eb9e5deaab565c0b27db2f3eb4dd4931 (patch)
treeab73ace15a741fd4d26a74aa528c7add7706e21e /dev-db
parentdev-db/spatialite: Drop old (diff)
downloadgentoo-9d383193eb9e5deaab565c0b27db2f3eb4dd4931.tar.gz
gentoo-9d383193eb9e5deaab565c0b27db2f3eb4dd4931.tar.bz2
gentoo-9d383193eb9e5deaab565c0b27db2f3eb4dd4931.zip
dev-db/spatialite-tools: Fix DEPENDs, HOMEPAGE, drop unused eclass
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..0f4302f052c7
--- /dev/null
+++ b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A collection of CLI tools supporting SpatiaLite"
+HOMEPAGE="https://www.gaia-gis.it/spatialite"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+RDEPEND="
+ dev-db/sqlite:3[extensions(+)]
+ >=dev-db/spatialite-3.0.1[geos,xls]
+ dev-libs/expat
+ dev-libs/libxml2
+ sci-geosciences/readosm
+ sci-libs/geos
+ sci-libs/proj
+ readline? (
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable readline)
+}