summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:55:16 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:50 +0100
commitfab2c1fc5055450758db1aa508d187db540bfd17 (patch)
treeae61b38381923367659437fccd6acc0a02bddfe6 /dev-db
parentdev-db/etcd: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-fab2c1fc5055450758db1aa508d187db540bfd17.tar.gz
gentoo-fab2c1fc5055450758db1aa508d187db540bfd17.tar.bz2
gentoo-fab2c1fc5055450758db1aa508d187db540bfd17.zip
dev-db/redis: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/redis-5.0.12.ebuild4
-rw-r--r--dev-db/redis/redis-5.0.13.ebuild4
-rw-r--r--dev-db/redis/redis-6.0.14.ebuild2
-rw-r--r--dev-db/redis/redis-6.0.15.ebuild2
-rw-r--r--dev-db/redis/redis-6.2.4.ebuild2
-rw-r--r--dev-db/redis/redis-6.2.5.ebuild2
6 files changed, 16 insertions, 0 deletions
diff --git a/dev-db/redis/redis-5.0.12.ebuild b/dev-db/redis/redis-5.0.12.ebuild
index fb5159d282a5..e3e81cea542e 100644
--- a/dev-db/redis/redis-5.0.12.ebuild
+++ b/dev-db/redis/redis-5.0.12.ebuild
@@ -158,3 +158,7 @@ src_install() {
fi
keepdir /var/{log,lib}/redis
}
+
+pkg_postinst() {
+ tmpfiles_process redis.conf
+}
diff --git a/dev-db/redis/redis-5.0.13.ebuild b/dev-db/redis/redis-5.0.13.ebuild
index fb5159d282a5..e3e81cea542e 100644
--- a/dev-db/redis/redis-5.0.13.ebuild
+++ b/dev-db/redis/redis-5.0.13.ebuild
@@ -158,3 +158,7 @@ src_install() {
fi
keepdir /var/{log,lib}/redis
}
+
+pkg_postinst() {
+ tmpfiles_process redis.conf
+}
diff --git a/dev-db/redis/redis-6.0.14.ebuild b/dev-db/redis/redis-6.0.14.ebuild
index d871156cf342..b61d5886247a 100644
--- a/dev-db/redis/redis-6.0.14.ebuild
+++ b/dev-db/redis/redis-6.0.14.ebuild
@@ -181,6 +181,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process redis.conf
+
ewarn "The default redis configuration file location changed to:"
ewarn " /etc/redis/{redis,sentinel}.conf"
ewarn "Please apply your changes to the new configuration files."
diff --git a/dev-db/redis/redis-6.0.15.ebuild b/dev-db/redis/redis-6.0.15.ebuild
index d871156cf342..b61d5886247a 100644
--- a/dev-db/redis/redis-6.0.15.ebuild
+++ b/dev-db/redis/redis-6.0.15.ebuild
@@ -181,6 +181,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process redis.conf
+
ewarn "The default redis configuration file location changed to:"
ewarn " /etc/redis/{redis,sentinel}.conf"
ewarn "Please apply your changes to the new configuration files."
diff --git a/dev-db/redis/redis-6.2.4.ebuild b/dev-db/redis/redis-6.2.4.ebuild
index 2546d4424d2b..5aa99d5a4880 100644
--- a/dev-db/redis/redis-6.2.4.ebuild
+++ b/dev-db/redis/redis-6.2.4.ebuild
@@ -181,6 +181,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process redis.conf
+
ewarn "The default redis configuration file location changed to:"
ewarn " /etc/redis/{redis,sentinel}.conf"
ewarn "Please apply your changes to the new configuration files."
diff --git a/dev-db/redis/redis-6.2.5.ebuild b/dev-db/redis/redis-6.2.5.ebuild
index a140e3a10280..76be65d5e4b4 100644
--- a/dev-db/redis/redis-6.2.5.ebuild
+++ b/dev-db/redis/redis-6.2.5.ebuild
@@ -181,6 +181,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process redis.conf
+
ewarn "The default redis configuration file location changed to:"
ewarn " /etc/redis/{redis,sentinel}.conf"
ewarn "Please apply your changes to the new configuration files."