summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/hawknl/hawknl-1.68-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/hawknl/hawknl-1.68-r2.ebuild')
-rw-r--r--dev-games/hawknl/hawknl-1.68-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-games/hawknl/hawknl-1.68-r2.ebuild b/dev-games/hawknl/hawknl-1.68-r2.ebuild
new file mode 100644
index 000000000000..59d79d329a71
--- /dev/null
+++ b/dev-games/hawknl/hawknl-1.68-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="A cross-platform network library designed for games"
+HOMEPAGE="http://www.hawksoft.com/hawknl/"
+SRC_URI="http://www.sonic.net/~philf/download/HawkNL${PV/./}src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}/hawknl${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i\ -e '/echo /d' src/makefile.linux || die
+}
+
+src_compile() {
+ emake -C src -f makefile.linux \
+ CC="$(tc-getCC)" \
+ OPTFLAGS="${CFLAGS} -D_GNU_SOURCE -D_REENTRANT"
+}
+
+src_install() {
+ emake -j1 -C src -f makefile.linux \
+ LIBDIR="${D}/usr/$(get_libdir)" \
+ INCDIR="${D}/usr/include" install
+ if use doc ; then
+ dodoc -r samples
+ fi
+}