summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 20:15:48 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:50 +0000
commitea5b73bc72ac49448d4c53f3f8c783ba34363528 (patch)
tree4882cb6120d9d7fc24c15f78b0fcd3287f78c236 /dev-haskell/async/async-2.2.4.ebuild
parentdev-haskell/assoc: new package, add 1.0.2 (diff)
downloadgentoo-ea5b73bc72ac49448d4c53f3f8c783ba34363528.tar.gz
gentoo-ea5b73bc72ac49448d4c53f3f8c783ba34363528.tar.bz2
gentoo-ea5b73bc72ac49448d4c53f3f8c783ba34363528.zip
dev-haskell/async: add 2.2.4
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/async/async-2.2.4.ebuild')
-rw-r--r--dev-haskell/async/async-2.2.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/async/async-2.2.4.ebuild b/dev-haskell/async/async-2.2.4.ebuild
new file mode 100644
index 000000000000..8d3cd7b0109b
--- /dev/null
+++ b/dev-haskell/async/async-2.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -bench
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="1"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bench
+}