summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-16 22:13:37 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-16 22:14:31 +0000
commit6e904b116584cc22b6203d9205781f4572d91170 (patch)
treeb928c98e8722a98cbaf597eafde2b57896c85877 /dev-haskell/ed25519/ed25519-0.0.5.0.ebuild
parentnet-misc/networkmanager: Fix kernel .config checks (#605826 by Anton Bolshakov) (diff)
downloadgentoo-6e904b116584cc22b6203d9205781f4572d91170.tar.gz
gentoo-6e904b116584cc22b6203d9205781f4572d91170.tar.bz2
gentoo-6e904b116584cc22b6203d9205781f4572d91170.zip
dev-haskell/ed25519: new package, a depend of hackport
Ed25519 cryptographic signatures Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/ed25519/ed25519-0.0.5.0.ebuild')
-rw-r--r--dev-haskell/ed25519/ed25519-0.0.5.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild b/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild
new file mode 100644
index 000000000000..20c323029fd5
--- /dev/null
+++ b/dev-haskell/ed25519/ed25519-0.0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +no-donna,+test-doctests,+test-properties,-test-hlint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Ed25519 cryptographic signatures"
+HOMEPAGE="http://thoughtpolice.github.com/hs-ed25519"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/doctest-0.10
+ >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ghc-prim >= 0.1 && < 0.5' 'ghc-prim >= 0.1' \
+ 'doctest >= 0.10 && < 0.11' 'doctest >= 0.10' \
+ 'QuickCheck >= 2.4 && < 2.9' 'QuickCheck >= 2.4' \
+ 'directory >= 1.0 && < 1.3' 'directory >= 1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=no-donna \
+ --flag=test-doctests \
+ --flag=-test-hlint \
+ --flag=test-properties
+}