summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 23:01:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commit9af2c1faee50f20cf89a62ab03a8253d00f5ce14 (patch)
tree304977d4645c9ae985db38e8deb48ac6e7debfd9 /dev-haskell/filestore
parentdev-haskell/frown: bump up to 0.6.2.3 (diff)
downloadgentoo-9af2c1faee50f20cf89a62ab03a8253d00f5ce14.tar.gz
gentoo-9af2c1faee50f20cf89a62ab03a8253d00f5ce14.tar.bz2
gentoo-9af2c1faee50f20cf89a62ab03a8253d00f5ce14.zip
dev-haskell/filestore: allow ghc-8
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/filestore')
-rw-r--r--dev-haskell/filestore/files/filestore-0.6.1-ghc-8.patch14
-rw-r--r--dev-haskell/filestore/filestore-0.6.1.ebuild10
2 files changed, 23 insertions, 1 deletions
diff --git a/dev-haskell/filestore/files/filestore-0.6.1-ghc-8.patch b/dev-haskell/filestore/files/filestore-0.6.1-ghc-8.patch
new file mode 100644
index 000000000000..126a0564b4db
--- /dev/null
+++ b/dev-haskell/filestore/files/filestore-0.6.1-ghc-8.patch
@@ -0,0 +1,14 @@
+diff --git a/Data/FileStore/Types.hs b/Data/FileStore/Types.hs
+index e950c7a..e116761 100644
+--- a/Data/FileStore/Types.hs
++++ b/Data/FileStore/Types.hs
+@@ -152,3 +152,3 @@ data FileStore = FileStore {
+ -- | Save contents in the filestore.
+- , save :: Contents a
++ , save :: forall a . Contents a
+ => FilePath -- Resource to save.
+@@ -160,3 +160,3 @@ data FileStore = FileStore {
+ -- | Retrieve the contents of the named resource.
+- , retrieve :: Contents a
++ , retrieve :: forall a . Contents a
+ => FilePath -- Resource to retrieve.
diff --git a/dev-haskell/filestore/filestore-0.6.1.ebuild b/dev-haskell/filestore/filestore-0.6.1.ebuild
index 944819418c1c..61f23d46549a 100644
--- a/dev-haskell/filestore/filestore-0.6.1.ebuild
+++ b/dev-haskell/filestore/filestore-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,14 @@ DEPEND+="
)
"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
+
+ cabal_chdeps \
+ 'time >= 1.1 && < 1.6' 'time >= 1.1' \
+ 'process >= 1.0 && < 1.3' 'process >= 1.0'
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag maxcount maxcount)