summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:45 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:53 +0100
commit0ec7ebf83f8055f4a9e3003d76a77db44165debb (patch)
tree77f1930e352bd8240858995a56ba70493bb92ce7 /dev-haskell/missingh/missingh-1.6.0.0.ebuild
parentdev-haskell/microstache: add 1.0.2.3-r1 (diff)
downloadgentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.tar.gz
gentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.tar.bz2
gentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.zip
dev-haskell/missingh: add 1.6.0.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/missingh/missingh-1.6.0.0.ebuild')
-rw-r--r--dev-haskell/missingh/missingh-1.6.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/missingh/missingh-1.6.0.0.ebuild b/dev-haskell/missingh/missingh-1.6.0.0.ebuild
new file mode 100644
index 000000000000..ccd03c06605a
--- /dev/null
+++ b/dev-haskell/missingh/missingh-1.6.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: +network--ge-3_0_0
+
+CABAL_PN="MissingH"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Large utility library"
+HOMEPAGE="https://hackage.haskell.org/package/MissingH"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+RDEPEND=">=dev-haskell/hslogger-1.3.0.0:=[profile?] <dev-haskell/hslogger-1.4:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.8.1:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/old-time-1.1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ || ( dev-lang/ghc ( >=dev-haskell/process-1.1.0.1[profile?] <dev-haskell/process-1.7[profile?] ) )
+ >=dev-haskell/regex-compat-0.95.1:=[profile?] <dev-haskell/regex-compat-0.96:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network--ge-3_0_0
+}