summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/monad-par
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/monad-par')
-rw-r--r--dev-haskell/monad-par/Manifest1
-rw-r--r--dev-haskell/monad-par/metadata.xml26
-rw-r--r--dev-haskell/monad-par/monad-par-0.3.4.7.ebuild45
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/monad-par/Manifest b/dev-haskell/monad-par/Manifest
new file mode 100644
index 000000000000..b7b503afc0fa
--- /dev/null
+++ b/dev-haskell/monad-par/Manifest
@@ -0,0 +1 @@
+DIST monad-par-0.3.4.7.tar.gz 30411 SHA256 23b8a68719b4c5848ce9a3381ce9efdc1c96677ba043a3ee74d99223343cc28a SHA512 eb9bd155589e9e7aea51e8b79f7fca20cfc8ac0dabf9c475fbbb312139311d567e1f19779247fd331c8242c93c9cefc1d52fca599c6444f90194d2a193182772 WHIRLPOOL 306063d25c5530f37781ec5e89ca0293216850d6c275d1ff668be36f1e91ea9495f9af1eaaaa3196353fab1774d1da101b946a4a44bf0f39a91e64049d68140c
diff --git a/dev-haskell/monad-par/metadata.xml b/dev-haskell/monad-par/metadata.xml
new file mode 100644
index 000000000000..33ab394d65e2
--- /dev/null
+++ b/dev-haskell/monad-par/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library offers an alternative parallel programming
+ API to that provided by the @parallel@ package.
+ The 'Par' monad allows the simple description of
+ parallel computations, and can be used to add
+ parallelism to pure Haskell code. The basic API
+ is straightforward: the monad supports forking
+ and simple communication in terms of 'IVar's.
+ The library comes with an efficient work-stealing
+ implementation, but the internals are also
+ exposed so that you can build your own scheduler
+ if necessary.
+ Examples of use can be found in the examples/ directory
+ of the source package.
+ </longdescription>
+ <use>
+ <flag name="chaselev">Use Chase-Lev Deques for higher-perf work-stealing.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">simonmar/monad-par</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild b/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
new file mode 100644
index 000000000000..84141b625027
--- /dev/null
+++ b/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -newgeneric
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for parallel programming based on a monad"
+HOMEPAGE="https://github.com/simonmar/monad-par"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="chaselev"
+
+RDEPEND=">=dev-haskell/abstract-deque-0.1.4:=[profile?]
+ dev-haskell/abstract-par:=[profile?]
+ >=dev-haskell/monad-par-extras-0.3:=[profile?]
+ >=dev-haskell/mtl-2.0.1.0:=[profile?]
+ >=dev-haskell/mwc-random-0.11:=[profile?]
+ >=dev-haskell/parallel-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ chaselev? ( dev-haskell/chaselev-deque:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.3
+ dev-haskell/test-framework-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag chaselev chaselev) \
+ --flag=-newgeneric
+}