summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-16 22:18:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-16 22:19:10 +0100
commitf307abf0bacb381d0cf037632c6e10ccd57c3d1e (patch)
tree338d8e88b5cfc5ba5ca3ce8b386d39f06d82e3e2 /dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
parentvirtual/commonlisp: Updates EAPI, lisp implementation and KEYWORDS (diff)
downloadgentoo-f307abf0bacb381d0cf037632c6e10ccd57c3d1e.tar.gz
gentoo-f307abf0bacb381d0cf037632c6e10ccd57c3d1e.tar.bz2
gentoo-f307abf0bacb381d0cf037632c6e10ccd57c3d1e.zip
dev-haskell/snap-core: allow ghc-8, bug #611706
Reported-by: Zentoo Bug: https://bugs.gentoo.org/611706 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/snap-core/snap-core-0.9.8.0.ebuild')
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.8.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
index 4fa5a429c1b4..ed5746eb2b61 100644
--- a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
+++ b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.0 && < 1.6' 'time >= 1.0'
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag debug debug) \