summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/snap-core/snap-core-0.9.8.0.ebuild')
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.8.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
index 4fa5a429c1b4..ed5746eb2b61 100644
--- a/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
+++ b/dev-haskell/snap-core/snap-core-0.9.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.0 && < 1.6' 'time >= 1.0'
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag debug debug) \