summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-01 09:29:21 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:57 +0100
commit5cd9f05400afe67c5c26094a106c40c73cb0e219 (patch)
treebd21fba0de6946e6ae3eeddf861e227d34ada5c6 /dev-haskell/uuid/uuid-1.3.13-r1.ebuild
parentdev-haskell/cryptohash-sha1: add package (diff)
downloadgentoo-5cd9f05400afe67c5c26094a106c40c73cb0e219.tar.gz
gentoo-5cd9f05400afe67c5c26094a106c40c73cb0e219.tar.bz2
gentoo-5cd9f05400afe67c5c26094a106c40c73cb0e219.zip
dev-haskell/uuid: bump up to 1.3.13
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/uuid/uuid-1.3.13-r1.ebuild')
-rw-r--r--dev-haskell/uuid/uuid-1.3.13-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/uuid/uuid-1.3.13-r1.ebuild b/dev-haskell/uuid/uuid-1.3.13-r1.ebuild
new file mode 100644
index 000000000000..31f07bace4ef
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.13-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/hvr/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
+ >=dev-haskell/entropy-0.3.7:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.10' 'QuickCheck >= 2.4' \
+ 'time >= 1.1 && < 1.8' 'time >= 1.1' \
+ 'tasty >= 0.10 && < 0.12' 'tasty >= 0.10' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'HUnit >= 1.2 && < 1.4' 'HUnit >= 1.2' \
+ 'entropy >= 0.3.7 && < 0.4' 'entropy >= 0.3.7'
+}