summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-18 08:34:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-18 08:36:39 +0000
commitff232f146979afe9a9d5e035eab03465f4d78297 (patch)
tree082ad7778b57e5d80f705e969af3ccc25eb4d9b8 /dev-haskell
parentdev-haskell/skylighting-core: bump up to 0.10.2 (diff)
downloadgentoo-ff232f146979afe9a9d5e035eab03465f4d78297.tar.gz
gentoo-ff232f146979afe9a9d5e035eab03465f4d78297.tar.bz2
gentoo-ff232f146979afe9a9d5e035eab03465f4d78297.zip
dev-haskell/skylighting: bump up to 0.10.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/skylighting/Manifest1
-rw-r--r--dev-haskell/skylighting/skylighting-0.10.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/Manifest b/dev-haskell/skylighting/Manifest
index 89608250e239..99667335661e 100644
--- a/dev-haskell/skylighting/Manifest
+++ b/dev-haskell/skylighting/Manifest
@@ -1 +1,2 @@
+DIST skylighting-0.10.2.tar.gz 633776 BLAKE2B 9f8899a7ad65e812009299f385033250d0ddc467d9f2574709a896bda45a27abf9d1ef275dd4b33ad351055b6f4476881f60a7f14cd21cd15da2b15cb10e17a4 SHA512 04d411580caf6102e3f8732c53b103412c6d42becfadbbcdd13053557235b632f07d82b22acad87ffc37f5705a387367aa21a0b70b1c5cf2ef52acce1b3e4e86
DIST skylighting-0.8.5.tar.gz 621391 BLAKE2B f17c1e729b2f669950ffec8a84bd9018acbd407f1c8c05bcbe65d77986ce72cdf55b0e967ce4070cd72e5a12fe469ee55cc3782401cc15f19da213a5fa92d592 SHA512 9d40d96020a3b54d549259f6c981ff63f666f490e900f29eda437ed76965f172e9c77c4def36850e448ca0d3fad035ce4e9a244fd0b3748c6c24fb413c69614f
diff --git a/dev-haskell/skylighting/skylighting-0.10.2.ebuild b/dev-haskell/skylighting/skylighting-0.10.2.ebuild
new file mode 100644
index 000000000000..69413875bb52
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bootstrap,+system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="~dev-haskell/skylighting-core-0.10.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ executable? ( >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/pretty-show:=[profile?]
+ dev-haskell/text:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}