summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/odfdom/odfdom-0.8.6-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/odfdom/odfdom-0.8.6-r1.ebuild')
-rw-r--r--dev-java/odfdom/odfdom-0.8.6-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/odfdom/odfdom-0.8.6-r1.ebuild b/dev-java/odfdom/odfdom-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..201aea7f09e0
--- /dev/null
+++ b/dev-java/odfdom/odfdom-0.8.6-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The ODFDOM reference implementation, written in Java"
+HOMEPAGE="http://odftoolkit.org/projects/odfdom"
+SRC_URI="http://odftoolkit.org/projects/odfdom/downloads/download/current-version%252F${P}-sources.zip -> ${P}-sources.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/xerces:2
+ dev-java/xml-commons-external:1.4"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/hamcrest-core:0
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${P}-sources"
+
+EANT_GENTOO_CLASSPATH="xerces-2,xml-commons-external-1.4"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ cp "${FILESDIR}/build-${PV}.xml" build.xml || die
+
+ mkdir lib || die
+
+ # These tests fail.
+ rm -v src/test/java/org/odftoolkit/odfdom/doc/DocumentCreationTest.java \
+ src/test/java/org/odftoolkit/odfdom/doc/PresentationTest.java \
+ src/test/java/org/odftoolkit/odfdom/doc/ImageTest.java \
+ src/test/java/org/odftoolkit/odfdom/incubator/meta/MetaDocumentStatisticTest.java \
+ src/test/java/org/odftoolkit/odfdom/incubator/meta/OfficeMetaTest.java
+}
+
+EANT_BUILD_TARGET="package"
+EANT_JAVADOC_TARGET="javadoc"
+EANT_EXTRA_ARGS="-Dmaven.test.skip=true"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},hamcrest-core,junit-4"
+
+src_test() {
+ EANT_EXTRA_ARGS="" \
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/odfdom.jar
+
+ dodoc README.txt LICENSE.txt || die
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}