summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild')
-rw-r--r--dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild b/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..40a626bf57f2
--- /dev/null
+++ b/dev-java/sun-java3d-bin/sun-java3d-bin-1.3.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+DESCRIPTION="Sun Java3D API Core"
+HOMEPAGE="https://j3d-core.dev.java.net/"
+SRC_URI="amd64? ( java3d-${PV//./_}-linux-amd64.zip )
+ x86? ( java3d-${PV//./_}-linux-i586.zip )"
+KEYWORDS="-* amd64 x86"
+SLOT="0"
+LICENSE="sun-jrl sun-jdl"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}/${A/.zip/}
+
+pkg_nofetch() {
+ einfo "Please download java3d-${PV//./_}-linux-${ARCH/x86/i586}.zip from"
+ einfo "${HOMEPAGE} and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip -q j3d-132-linux-${ARCH}.zip || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodoc COPYRIGHT.txt README.txt
+
+ java-pkg_dojar lib/ext/*.jar
+ java-pkg_doso lib/${ARCH/x86/i386}/*.so
+}
+
+pkg_postinst() {
+ elog "This ebuild installs into /opt/${PN} and /usr/share/${PN}"
+ elog 'To use you need to pass the following to java'
+ elog '-Djava.library.path=$(java-config -i sun-java3d-bin) -cp $(java-config -p sun-java3d-bin)'
+}