summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-01 22:43:43 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-01 22:43:43 +0100
commiteb143fae3bca40c52cfbf6f96b9a439dc26b0976 (patch)
treeeff7ca4c666d9e27ef9c753ee9f177800d383b56 /dev-lang/gnat-gpl
parentgames-emulation/pcsx2: unbundle cubeb+libchdr, make pulse optional (diff)
downloadgentoo-eb143fae3bca40c52cfbf6f96b9a439dc26b0976.tar.gz
gentoo-eb143fae3bca40c52cfbf6f96b9a439dc26b0976.tar.bz2
gentoo-eb143fae3bca40c52cfbf6f96b9a439dc26b0976.zip
dev-lang/gnat-gpl: fix cet detection
Closes: https://bugs.gentoo.org/830345 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/files/gnat-gpl-2021-gentoo.patch10
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild7
2 files changed, 16 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/files/gnat-gpl-2021-gentoo.patch b/dev-lang/gnat-gpl/files/gnat-gpl-2021-gentoo.patch
index 3caa2a6d996e..2bfc54c551a9 100644
--- a/dev-lang/gnat-gpl/files/gnat-gpl-2021-gentoo.patch
+++ b/dev-lang/gnat-gpl/files/gnat-gpl-2021-gentoo.patch
@@ -39,3 +39,13 @@
+ %{fdump-scos:-fpreserve-decisions-generic}\
%{fprofile-arcs|fprofile-generate*|coverage:\
- %{!fprofile-update=singel:\
+--- a/gcc-10-2021-20210519-19A74-src/config/cet.m4 2022-01-01 11:18:09.663425422 +0100
++++ b/gcc-10-2021-20210519-19A74-src/config/cet.m4 2022-01-01 11:18:14.809345911 +0100
+@@ -62,7 +62,6 @@
+ i[[34567]]86-*-linux* | x86_64-*-linux*)
+ may_have_cet=yes
+ save_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -fcf-protection"
+ case "$enable_cet" in
+ auto)
+ # Check if target supports multi-byte NOPs
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
index 3502c2c009fd..60a6e2908ead 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -87,6 +87,11 @@ src_prepare() {
ln -s /usr/bin/$CHOST-ld \
"${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
|| die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
+ ln -s /usr/bin/$CHOST-as \
+ "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
fi
CC=${GCC}