summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-25 00:02:44 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-25 00:03:18 -0500
commit0d97903e14721b3bb2844db998fd1ce3d17b1cda (patch)
treec781638b72b975e4d99b0303390f2217b0d6338d /dev-lang/php
parentmedia-video/mkvtoolnix: add ruby:2.3 build support (bug #570116) (diff)
downloadgentoo-0d97903e14721b3bb2844db998fd1ce3d17b1cda.tar.gz
gentoo-0d97903e14721b3bb2844db998fd1ce3d17b1cda.tar.bz2
gentoo-0d97903e14721b3bb2844db998fd1ce3d17b1cda.zip
dev-lang/php: revision the 5.6 and 7.0 series to add pdo-firebird support.
PHP has two Firebird drivers -- the legacy "interbase" driver and the new pdo-firebird driver. We have always supported the legacy driver with USE=firebird, but were missing the pdo-firebird configure flag when USE="pdo firebird" was set. Similar tricks were in place for e.g. sqlite and oci8, but Firebird was forgotten. Dmitry A. Bakshaev was nice enough to point this out in bug 538226, and even supplied a patch. Testing shows that both drivers work in php:5.6, but that only the PDO driver works in php:7.0. That's not a regression; this commit adds the only driver that works in php:7.0. Gentoo-Bug: 538226 Suggested-By: Dmitry A. Bakshaev Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-5.6.17-r2.ebuild (renamed from dev-lang/php/php-5.6.17-r1.ebuild)1
-rw-r--r--dev-lang/php/php-7.0.2-r2.ebuild (renamed from dev-lang/php/php-7.0.2-r1.ebuild)1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-lang/php/php-5.6.17-r1.ebuild b/dev-lang/php/php-5.6.17-r2.ebuild
index 8addecce213e..df8096ca6faf 100644
--- a/dev-lang/php/php-5.6.17-r1.ebuild
+++ b/dev-lang/php/php-5.6.17-r2.ebuild
@@ -476,6 +476,7 @@ src_configure() {
$(use_with mysql pdo-mysql "${mysqllib}")
$(use_with postgres pdo-pgsql)
$(use_with sqlite pdo-sqlite "${EPREFIX}/usr")
+ $(use_with firebird pdo-firebird "${EPREFIX}/usr")
$(use_with odbc pdo-odbc "unixODBC,${EPREFIX}/usr")
$(use_with oci8-instant-client pdo-oci)
)
diff --git a/dev-lang/php/php-7.0.2-r1.ebuild b/dev-lang/php/php-7.0.2-r2.ebuild
index 45daa6d4c509..6ecf27ac71ee 100644
--- a/dev-lang/php/php-7.0.2-r1.ebuild
+++ b/dev-lang/php/php-7.0.2-r2.ebuild
@@ -465,6 +465,7 @@ src_configure() {
$(use_with mysql pdo-mysql "${mysqllib}")
$(use_with postgres pdo-pgsql)
$(use_with sqlite pdo-sqlite "${EPREFIX}/usr")
+ $(use_with firebird pdo-firebird "${EPREFIX}/usr")
$(use_with odbc pdo-odbc "unixODBC,${EPREFIX}/usr")
$(use_with oci8-instant-client pdo-oci)
)