summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 20:31:05 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-20 20:31:05 +0100
commite0e8685468fa06ca70d56e828ae678df3c517831 (patch)
treefc6fa230a0ebd7a723fa3c5dc238a7c65540132d /dev-lang
parentapp-laptop/pbbuttonsd: Port to EAPI 7 (diff)
downloadgentoo-e0e8685468fa06ca70d56e828ae678df3c517831.tar.gz
gentoo-e0e8685468fa06ca70d56e828ae678df3c517831.tar.bz2
gentoo-e0e8685468fa06ca70d56e828ae678df3c517831.zip
dev-lang/pcc: Port to EAPI 7
Closes: https://bugs.gentoo.org/712364 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pcc/files/pcc-1.1.0-multiarch.patch4
-rw-r--r--dev-lang/pcc/pcc-1.1.0-r1.ebuild26
2 files changed, 13 insertions, 17 deletions
diff --git a/dev-lang/pcc/files/pcc-1.1.0-multiarch.patch b/dev-lang/pcc/files/pcc-1.1.0-multiarch.patch
index 8420908e9f9d..8ee850ea655d 100644
--- a/dev-lang/pcc/files/pcc-1.1.0-multiarch.patch
+++ b/dev-lang/pcc/files/pcc-1.1.0-multiarch.patch
@@ -1,5 +1,5 @@
---- cc/cc/cc.c 2014-12-06 09:52:55.000000000 +0000
-+++ cc/cc/cc.c.new 2015-03-09 09:22:25.569376330 +0000
+--- a/cc/cc/cc.c
++++ b/cc/cc/cc.c
@@ -206,7 +206,7 @@
#define PCCLIBDIR NULL
#endif
diff --git a/dev-lang/pcc/pcc-1.1.0-r1.ebuild b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
index e360baaad232..b4e31f8eea76 100644
--- a/dev-lang/pcc/pcc-1.1.0-r1.ebuild
+++ b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils versionator autotools
+inherit autotools flag-o-matic
DESCRIPTION="pcc portable c compiler"
HOMEPAGE="http://pcc.ludd.ltu.se"
@@ -13,25 +13,21 @@ SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
DEPEND=">=dev-libs/pcc-libs-${PV}"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-multiarch.patch )
+
src_prepare() {
- sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' configure.ac || die "Failed to fix configure.ac"
- sed -i -e 's/AC_SUBST(strip)//' configure.ac || die "Failed to fix configure.ac more"
+ default
+ sed -i \
+ -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' \
+ -e 's/AC_SUBST(strip)//' configure.ac || die
eautoreconf
- epatch "${FILESDIR}/${P}-multiarch.patch" || die
}
src_configure() {
+ append-cflags -fcommon
econf --disable-stripping
}
-
-src_compile() {
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-}