summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-09-29 09:32:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-30 10:06:39 +0300
commitac980372dc0487ad5f8f773dba883bb7f32a679f (patch)
tree0df9f5f4afcac629b4ad4af6fec7dc704716222d /dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
parentdev-libs/libstrophe: state explicitly that testing is enabled (diff)
downloadgentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.tar.gz
gentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.tar.bz2
gentoo-ac980372dc0487ad5f8f773dba883bb7f32a679f.zip
dev-libs/aws-c-common: Remove -Werror from build FLAGS
Issue: dev-libs/aws-c-common-0.4.57 uses -Werror for build. Discovered on: amd64 (internal ref: ci) -Werror is not recommended for releases and should always be disabled when encountered in build-logs, because there are numerous cases where this breaks without purpose. Closes: https://bugs.gentoo.org/745093 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild')
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
new file mode 100644
index 000000000000..120faea56d6a
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-Werror-CFLAG.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}