summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-10-23 09:26:21 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-23 10:36:53 +0300
commit7016c60063e9a3e130a46d99d0387a64461cc03f (patch)
treef721017d36a2b6e2b05162a2fa5cb2581e5a00a5 /dev-libs/dqlite/dqlite-1.6.0.ebuild
parentdev-libs/raft: new package (diff)
downloadgentoo-7016c60063e9a3e130a46d99d0387a64461cc03f.tar.gz
gentoo-7016c60063e9a3e130a46d99d0387a64461cc03f.tar.bz2
gentoo-7016c60063e9a3e130a46d99d0387a64461cc03f.zip
dev-libs/dqlite: new package
- embeddable, replicated and fault tolerant SQL engine, - dep of lxd. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.6.0.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.6.0.ebuild b/dev-libs/dqlite/dqlite-1.6.0.ebuild
new file mode 100644
index 000000000000..0c27bdc01621
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv
+ dev-libs/raft"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/raft[test] )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-sanitize
+ )
+
+ econf "${myeconfargs[@]}"
+}