summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.6.0.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.6.0.ebuild b/dev-libs/dqlite/dqlite-1.6.0.ebuild
new file mode 100644
index 000000000000..0c27bdc01621
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv
+ dev-libs/raft"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/raft[test] )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-sanitize
+ )
+
+ econf "${myeconfargs[@]}"
+}