summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-03-02 14:28:59 +0100
committerMichael Weber <xmw@gentoo.org>2017-03-02 18:35:34 +0100
commit56f514c9ab3a17e55d064159f69c62f5d45dee91 (patch)
tree61bf859d6d73996e52dde0a4037b17753cb21507 /dev-libs/libcxml
parentdev-util/waf: Initial import (diff)
downloadgentoo-56f514c9ab3a17e55d064159f69c62f5d45dee91.tar.gz
gentoo-56f514c9ab3a17e55d064159f69c62f5d45dee91.tar.bz2
gentoo-56f514c9ab3a17e55d064159f69c62f5d45dee91.zip
dev-libs/libcxml: Initial import for libdcp.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-libs/libcxml')
-rw-r--r--dev-libs/libcxml/Manifest2
-rw-r--r--dev-libs/libcxml/files/libcxml-0.15.1-respect-cxxflags.patch11
-rw-r--r--dev-libs/libcxml/libcxml-0.15.1.ebuild23
-rw-r--r--dev-libs/libcxml/libcxml-0.15.4.ebuild23
-rw-r--r--dev-libs/libcxml/metadata.xml8
5 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/libcxml/Manifest b/dev-libs/libcxml/Manifest
new file mode 100644
index 000000000000..7861c401b3f6
--- /dev/null
+++ b/dev-libs/libcxml/Manifest
@@ -0,0 +1,2 @@
+DIST libcxml-0.15.1.tar.bz2 137082 SHA256 7e81dcd0bdb6ea6aaff84bd176f3100cc9ed409bf8d87894abef4ff0b9736dce SHA512 91bcc8334ef5e71126701e850211928304561ca27a03e4b8d528fbc6d94fe2635c753c3b3b8ecec185e76fc5a70f426f6dfee72b4a432898435d2bfc1764b10e WHIRLPOOL bac7b56f30db5b2883edd1901a3d0d7cd50cb3ab3ee0017026d4db10294c4978e7c2a17c275cc4123bab3b07735dc34f30d57fb3287524beaf9662c65a59a7cd
+DIST libcxml-0.15.4.tar.bz2 137251 SHA256 945e513b5eb366d34a71b965733d583b621201070103826356318783502f0d29 SHA512 b14a29eaa502451eb293ce2faf2424c6e8147d6e28e86911c7adba5d1f725a5500772e2199d57834daee503de0458480f7cbf39c0d83db8afb4998db0b0b44ca WHIRLPOOL ae5c8927ac7954c8314490a929ba661970cff8e86b0ac11d02b962a594d997f43c9ef18dad1182745eaf0bd74b958017d6433942ec1cfd94da244783086ed7f8
diff --git a/dev-libs/libcxml/files/libcxml-0.15.1-respect-cxxflags.patch b/dev-libs/libcxml/files/libcxml-0.15.1-respect-cxxflags.patch
new file mode 100644
index 000000000000..409dc37410c1
--- /dev/null
+++ b/dev-libs/libcxml/files/libcxml-0.15.1-respect-cxxflags.patch
@@ -0,0 +1,11 @@
+--- libcxml-0.15.1/wscript
++++ libcxml-0.15.1/wscript
+@@ -12,7 +12,7 @@
+
+ def configure(conf):
+ conf.load('compiler_cxx')
+- conf.env.append_value('CXXFLAGS', ['-Wall', '-Wextra', '-O2'])
++ conf.env.append_value('CXXFLAGS', ['-Wall', '-Wextra'])
+
+ conf.env.TARGET_WINDOWS = conf.options.target_windows
+ conf.env.STATIC = conf.options.static
diff --git a/dev-libs/libcxml/libcxml-0.15.1.ebuild b/dev-libs/libcxml/libcxml-0.15.1.ebuild
new file mode 100644
index 000000000000..e026d6e56307
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-0.15.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="small C++ library which makes it marginally neater to parse XML using libxml++"
+HOMEPAGE="http://carlh.net/libcxml"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.1-respect-cxxflags.patch )
diff --git a/dev-libs/libcxml/libcxml-0.15.4.ebuild b/dev-libs/libcxml/libcxml-0.15.4.ebuild
new file mode 100644
index 000000000000..e026d6e56307
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-0.15.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="small C++ library which makes it marginally neater to parse XML using libxml++"
+HOMEPAGE="http://carlh.net/libcxml"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.1-respect-cxxflags.patch )
diff --git a/dev-libs/libcxml/metadata.xml b/dev-libs/libcxml/metadata.xml
new file mode 100644
index 000000000000..a535b8852829
--- /dev/null
+++ b/dev-libs/libcxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>