summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-31 10:16:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 16:50:49 +0100
commit5792d478c1aa0a81d837c303de86beae16962522 (patch)
tree8850899b535fe98c6634adf769225806c3d048d4 /dev-libs/libixion/libixion-9999.ebuild
parentgames-engines/box2d: Drop slotted versions 2.1.2, 2.2.1, 2.3.1 (diff)
downloadgentoo-5792d478c1aa0a81d837c303de86beae16962522.tar.gz
gentoo-5792d478c1aa0a81d837c303de86beae16962522.tar.bz2
gentoo-5792d478c1aa0a81d837c303de86beae16962522.zip
dev-libs/libixion: 0.16.1 version bump, no KEYWORDS for now
Closes: https://bugs.gentoo.org/766971 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libixion/libixion-9999.ebuild')
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index c1793b33a8dc..96e5b7ce6f18 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
@@ -30,9 +30,7 @@ RDEPEND="
dev-util/mdds:${MDDS_SLOT}
python? ( ${PYTHON_DEPS} )
"
-DEPEND="${RDEPEND}
- dev-libs/spdlog
-"
+DEPEND="${RDEPEND}"
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -47,6 +45,8 @@ src_configure() {
local myeconfargs=(
--disable-static
$(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
$(use_enable python)
$(use_enable threads)
)