summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion/libixion-9999.ebuild')
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index c1793b33a8dc..96e5b7ce6f18 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
@@ -30,9 +30,7 @@ RDEPEND="
dev-util/mdds:${MDDS_SLOT}
python? ( ${PYTHON_DEPS} )
"
-DEPEND="${RDEPEND}
- dev-libs/spdlog
-"
+DEPEND="${RDEPEND}"
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -47,6 +45,8 @@ src_configure() {
local myeconfargs=(
--disable-static
$(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
$(use_enable python)
$(use_enable threads)
)