summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:04:04 +0100
committerJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:39:56 +0100
commit4e2eddf6d3a55c4e23808446d9268e8fff4b2851 (patch)
tree01735b6f7b1c247a37868e9663a12b671050f1eb /dev-libs/npth/npth-1.7.ebuild
parentdev-build/bmake: drop 20231210 (diff)
downloadgentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.tar.gz
gentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.tar.bz2
gentoo-4e2eddf6d3a55c4e23808446d9268e8fff4b2851.zip
dev-libs/npth: add 1.7
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-libs/npth/npth-1.7.ebuild')
-rw-r--r--dev-libs/npth/npth-1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/npth/npth-1.7.ebuild b/dev-libs/npth/npth-1.7.ebuild
new file mode 100644
index 000000000000..71d952cdae8c
--- /dev/null
+++ b/dev-libs/npth/npth-1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}