summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 11:15:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 11:17:16 +0100
commitad2372cfd284cad95532615720b4c659d1dcaebf (patch)
tree78d29b5447244a18cfb978e5846eb3846beb5ffe /dev-libs/stp
parentdev-lisp/c2ffi: Switch to cmake.eclass (diff)
downloadgentoo-ad2372cfd284cad95532615720b4c659d1dcaebf.tar.gz
gentoo-ad2372cfd284cad95532615720b4c659d1dcaebf.tar.bz2
gentoo-ad2372cfd284cad95532615720b4c659d1dcaebf.zip
dev-libs/stp: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/stp')
-rw-r--r--dev-libs/stp/stp-2.3.3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/stp/stp-2.3.3.ebuild b/dev-libs/stp/stp-2.3.3.ebuild
index a900384b2178..69e3d1b92d74 100644
--- a/dev-libs/stp/stp-2.3.3.ebuild
+++ b/dev-libs/stp/stp-2.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
HOMEPAGE="https://stp.github.io/"
@@ -23,7 +23,7 @@ src_prepare() {
# replace static lib with $(get_libdir)
sed -i "s/set(LIBDIR lib/set(LIBDIR $(get_libdir)/" CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -33,11 +33,11 @@ src_configure() {
-DENABLE_PYTHON_INTERFACE="$(usex python)"
-DSTATICCOMPILE="$(usex static)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# don't install to /usr/man
doman "${D}/usr/man/man1/stp.1"