summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-09 15:35:04 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-09 15:35:28 +0100
commitfa81453aceb0ceef422c5ba90fd0f261c14dd8c2 (patch)
tree03a742f108e1bc830f24cb430a669a7a84f25d7d /dev-libs/weston/weston-9999.ebuild
parentsci-mathematics/geogebra: remove old (diff)
downloadgentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.tar.gz
gentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.tar.bz2
gentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.zip
dev-libs/weston: Version bump to 1.12.0, fix cross compilation
Based on contribution by Mykyta Holubakha. Closes: https://github.com/gentoo/gentoo/pull/2816 Bug: https://bugs.gentoo.org/show_bug.cgi?id=598238 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/weston/weston-9999.ebuild')
-rw-r--r--dev-libs/weston/weston-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 253af5431859..b63753841a87 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
@@ -27,7 +27,7 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp +resize-optimization screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
REQUIRED_USE="
drm? ( gles2 )
@@ -39,7 +39,7 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
- >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-1.12.0
>=dev-libs/wayland-protocols-1.2
lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
@@ -66,10 +66,6 @@ RDEPEND="
media-libs/mesa[gles2,wayland]
)
rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
- rpi? (
- >=sys-libs/mtdev-1.1.0
- >=virtual/udev-136
- )
systemd? (
sys-auth/pambase[systemd]
sys-apps/systemd[pam]
@@ -92,8 +88,11 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ default
if [[ ${PV} = 9999* ]]; then
eautoreconf
+ else
+ elibtoolize
fi
}
@@ -116,7 +115,6 @@ src_configure() {
$(use_enable ivi ivi-shell) \
$(use_enable lcms) \
$(use_enable rdp rdp-compositor) \
- $(use_enable rpi rpi-compositor) \
$(use_enable wayland-compositor) \
$(use_enable X x11-compositor) \
$(use_enable launch weston-launch) \
@@ -143,7 +141,7 @@ src_test() {
chmod 0700 "${XDG_RUNTIME_DIR}" || die
cd "${BUILD_DIR}" || die
- Xemake check
+ virtx emake check
}
src_install() {