summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-02-22 17:58:04 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-02-22 17:58:49 -0500
commitc769d98ebd374619987b0a8b78e4ba8929c328a7 (patch)
tree8ff1b8b266677722ffeb3e40158d4d127e367857 /dev-libs/xapian/xapian-1.4.10.ebuild
parentprofiles/categories: add new categories (diff)
downloadgentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.tar.gz
gentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.tar.bz2
gentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.zip
dev-libs/xapian: version bump to 1.4.10
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/xapian/xapian-1.4.10.ebuild')
-rw-r--r--dev-libs/xapian/xapian-1.4.10.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.4.10.ebuild b/dev-libs/xapian/xapian-1.4.10.ebuild
new file mode 100644
index 000000000000..ef53864e2d91
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}