summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 09:08:34 +0000
committerSam James <sam@gentoo.org>2021-01-27 09:12:04 +0000
commitdd1f2fcc8f9a58365b2b83599717336fec0683f3 (patch)
tree7c4560f7e8211bed9077af11b02db23a89868899 /dev-ml/async/async-0.14.0.ebuild
parentdev-ml/async_unix: bump to 0.14.0 (diff)
downloadgentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.tar.gz
gentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.tar.bz2
gentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.zip
dev-ml/async: bump to 0.14.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/async/async-0.14.0.ebuild')
-rw-r--r--dev-ml/async/async-0.14.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/async/async-0.14.0.ebuild b/dev-ml/async/async-0.14.0.ebuild
new file mode 100644
index 000000000000..5f2a17b7ce82
--- /dev/null
+++ b/dev-ml/async/async-0.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="https://github.com/janestreet/async"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+# Need qtest_lib, netkit_sockets
+# Unpackaged test deps
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/async_extra:=
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_jane:=
+ dev-ml/textutils:=
+"
+DEPEND="${RDEPEND}"